Springfield XD Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Every now and then, when using the extended mag, the slide does not lock back after shooting all the rounds.. No biggie at the range but it does worry me a tad about self defense situations. Any suggestions or ideas?
 

·
Registered
Joined
·
2,044 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
Wow, you weren't kidding, LOTS of threads asking similar question..

It's been a while since I was a part of any online forums, forgot about that handy search function. My bad.

I just think it's odd that it never happened on the flush mag, but you are probably right. I'm okay with it being my error rather than the firearm malfunctioning.

Thanks

Sent from my SCH-S720C using Tapatalk 2
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #5 ·
Well, it was certainly operator error, but it was NOT my thumb riding the slide release.

You should be proud, I also used the search function ;)

I pulled the slide back with my empty mags. The flush mag locked back, the extended mag however did not. So I get the mag apart and would you look at that.... There's the operator error! The spring was installed backwards.

Must have been distracted when reassembling the mag after cleaning. A little embarrassing, sure, but I thought I would post the results in case someone happens to goof up like I did and can't figure out what the deal is.

All is well now :rolleyes:

Sent from my SCH-S720C using Tapatalk 2
 

·
Registered
Joined
·
388 Posts
A few years back I had the same issue with my XD40sc and everyone said I was pushing it with my thumb. I had other people shoot it and they had the same problem and I watched them fire it and it was not them pushing anything with their thumb. I even tried to make it lock open but I could not. Called SA they said to send it in, I did, they fixed it and I have not had a problem since. From other people I have talked to the 40sc does have a few pistols with that problem and it can be fixed. SA did not tell me what the repair consisted of. Still works after thousands of rounds through it.
 

·
Registered
Joined
·
2,044 Posts
Thanks for the update.

kypix
 

·
Premium Member
Joined
·
1,574 Posts
Must have been distracted when reassembling the mag after cleaning. A little embarrassing, sure, but I thought I would post the results in case someone happens to goof up like I did and can't figure out what the deal is.

All is well now :rolleyes:
Thanks for posting the root cause for your issue. It will indeed help another shooter no doubt.
 
1 - 8 of 8 Posts
Top