Springfield XD Forum banner
1 - 20 of 29 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Has anyone had problems with. Their 4.0 I just bought one first time shooting game it it was issues returning into battery all the way anyone else have any issues?



Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
80 Posts
No issues with mine shooting both factory ammo and my lower power reloads. I did all of the PRP mods to it and polished the internals too.
I have it for sale in the classified section now.
 

·
Registered
Joined
·
358 Posts
I've got about four to five hundred rounds through mine since I got it a month or so ago... it's only failed to return one time and I believe it was more the ammunition fault than gun. Did you happen to see if your guide rod was lubed properly before shooting since it was the first time? Or do you notice any grittyness when cycling the slide?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
Actually I just took it out the box and shoot it I actually field stripped it once but didn't lube it or clean it . After the issues I went home and cleaned it and lubed it with gunzilla CLP I will see how it does today

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
11,292 Posts
I went home and cleaned it and lubed it with gunzilla CLP
Always highly recommended before putting any firearm through it's paces. ;)
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #6 ·
The thing was that when I tried to rack the slide it wouldn't go into full battery and even with a push it seemed to be jammed and I'm shooting winchester white box 115 grain

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
230 Posts
The thing was that when I tried to rack the slide it wouldn't go into full battery and even with a push it seemed to be jammed and I'm shooting winchester white box 115 grain

Sent from my SM-G900V using Tapatalk

If you are riding the slide - easing it into battery when you rack it - that's the problem. Pull it back all the way and just let it go.


If it's happening while you are actually shooting, it is a problem, either with the way you are shooting or the gun.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #8 ·
It was doing it while I was shooting also so idk what it could be im n pretty disappointed I'm a new guy to handguns so it kinda sucks

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
230 Posts
It was doing it while I was shooting also so idk what it could be im n pretty disappointed I'm a new guy to handguns so it kinda sucks

Sent from my SM-G900V using Tapatalk

If you can find a really competent shooter, have them see if they can reproduce the problem - that may determine if there is something wrong with the gun itself, or some technique improvements on your part are called for.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #11 ·
I'm not new guy to shooting but to guns I am so I'm pretty confident it's not my technique but I could be wrong

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #13 ·
Not offense taken but I'm pretty sure I'm not I've seen that happen before and this is diffrent the slide will be off by like 1/8 of and inch I will go test fire it today again and see if it happens and I will take a picture of it

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
416 Posts
Four hundred or so rounds downrange Remington UMC 115 gr, Blazer Brass, Winchester white box, Sellier & Bellot. No FTF NO FTE, No problems going into battery. It just shoots everything I put in it. Trigger is a little stiffer than my XD service, but I suspect as I get more rounds down range it should improve some. I like it and I'll carry it!
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #15 ·
So I just got done putting around 40 rounds through it rapid fire and some slow fire and I am so relieved to say it was flawless I think it just needed to be cleaned and lubed

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
1,942 Posts
Now you know why you clean and lube a new gun. I bought a new M&P and when I cleaned it it had a chunk if metal in the extractor hook. Some things are missed in a QC check.
 

·
Registered
Joined
·
74 Posts
Sweet, Glad things worked out for you. My buddy had a similar problem with his new Gen 3 Glock 23. He just had to lube it up, and it ran just fine.
 

·
Registered
Joined
·
290 Posts
Four hundred or so rounds downrange Remington UMC 115 gr, Blazer Brass, Winchester white box, Sellier & Bellot. No FTF NO FTE, No problems going into battery. It just shoots everything I put in it. Trigger is a little stiffer than my XD service, but I suspect as I get more rounds down range it should improve some. I like it and I'll carry it!
Ditto here. Trigger is still a little stiff but with only 250 rounds though it so far I expect it to get better. My XDm was the same way until about 400 rounds or so. Other than that I have absolutely no complaints with it.
 

·
Registered
Joined
·
41 Posts
And no I was not riding the slide

Sent from my SM-G900V using Tapatalk
The XDS is really picky with racking the slide, so don't take offense to someone telling you that you're riding the slide with the XDS. You should really be using the slide stop/release with this gun anyway.
 
1 - 20 of 29 Posts
Top