Springfield XD Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
268 Posts
Discussion Starter #1
I took my new 9mm to the range tonight and accuracy was great. i did have 13 FTF though. the new round hung up half way into the chamber. i only have 100 rounds through it. it this something that just shooting it and breaking it in will cure or should it go back?
 

·
Super Moderator
Joined
·
8,970 Posts
What kind of ammo? As you use your XD, the feed ramp will become more polished, which will help. That said, that is a lot of failure in one outing. I have never had that many, and I have thousands of rounds through my XDs.
 

·
Registered
Joined
·
268 Posts
Discussion Starter #3
I was using federal 147grn fmj tc bullets
 

·
Registered
Joined
·
31 Posts
Not normal, try different ammo first

if you still have the same prob Contact Springfield or the people you bought it from.
I've fed MANY types of ammo through mine including federal 147grn fmj and have never once had a FTF.

best of luck man
 

·
Premium Member
Joined
·
16,428 Posts

·
Registered
Joined
·
539 Posts
while i the mag may be cause, i think it would be wise to try different ammo first.
 

·
Premium Member
Joined
·
5,751 Posts
I've got lots of Fed 147s thru my 4" & 5". Never had a problem with them. Not sure how you were shooting, or your experience level with pistols, but with that many FTFs in one outing I would think you may be limp wristing. If you were benching and had the butt of the pistols resting on the bench its quite possible that your grip was loose while concentrating on trigger pull and sight alignment.
Another possibility is your grip. Your weak hand thumb may be riding high and be contacting the slide slightly, but enough to slow down the action of the slide. I ride the slide on my 1911s like a bum on a freight train.
Just some thoughts.
 

·
Registered
Joined
·
268 Posts
Discussion Starter #8
i shoot alot and i have never had a problem with any of my other pistols. i know limp grip can have an impact on proper function of the weapon so i make sure it was rock solid. i love the pistol i just need one that works. Thanks for all your help guys its great to have a place to go to get ansewrs.
 

·
Premium Member
Joined
·
5,751 Posts
Might go with Eric on trying a different ammo. Run some WWB ball through it and if it feeds ok, shoot a couple hundred and get it broke in then try the Fed again.
 

·
Registered
Joined
·
3 Posts
I've had failure to eject problems (about 2-3 every 5 boxes). The gunsmith said it's probably the CCI Blazer 9mm fouling the chamber. I'm cleaning the bore more often now to see if that helps. Anyone else having the same problem? He said if it keeps up he will polish the chamber.
 

·
Registered
Joined
·
268 Posts
Discussion Starter #11
Well all it needed was to get shot in a bit. i tore it down and cleaned and lubed it and shot it a bunch and it shoots like a dream. All it needed was to get shot in. the last 100 rnds not one problem. i love this thing
 

·
Registered
Joined
·
268 Posts
Discussion Starter #12
Well all it needed was to get shot in a bit. i tore it down and cleaned and lubed it and shot it a bunch and it shoots like a dream. All it needed was to get shot in. the last 100 rnds not one problem. i love this thing
 

·
Registered
Joined
·
539 Posts
kgpcr said:
Well all it needed was to get shot in a bit. i tore it down and cleaned and lubed it and shot it a bunch and it shoots like a dream. All it needed was to get shot in. the last 100 rnds not one problem. i love this thing

good to hear!
 
1 - 13 of 13 Posts
Top