Springfield XD Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter #1
I gave my XD-9 its first cleaning the other day i used Hoppes number 9 in the bore. But since then I have had it fail to eject the empty casing twice. It comes out about halfway then stops then of course it jams. Could the bore cleaner i used be too thick? or do I need to clean it again
 

·
Registered
Joined
·
72 Posts
My brother the amature gunsmith says to use Copper Solvent on the bore and CLP on everything else.

Try cleaning the extractor, changing ammo, changing stances, lastly have someone look at it.

My $0.02
 

·
Registered
Joined
·
2,078 Posts
I have had similiar problems with my XD in past. Try differnt ammo. If it is not ammo dependant, in other words keeps FTE with all ammo types, you need to have the extractor worked on. You can send it to Springfiled Armory or you can find yourself a good local gunsmith and ask him to tune the extractor. I think sending it to SA in this case is a crap shoot because I did that the first time and the issue came back in 1200 rounds even though they replaced the extractor. I ended up having my smith do it and it has performed flawlessly since. He tuned the tension and incresed positive camber on extractor hook. Any decent smith that works on 1911s should be able to help.
 

·
Registered
Joined
·
92 Posts
Discussion Starter #6
Yeah i been using the winchester white box ammo but I have shot about 500 rds with it and had no problem
 

·
Registered
Joined
·
63 Posts
I have almost had at least 1 FTE each time I have gone to the range. I have over 3000rnds. through my XD-9. I shoot WWB, Wolf, UMC, Fiocci and both CCI Blazer Brass and Aluminum. Tonight was the worst. I shot 200 rounds of CCI Blazer Brass and had 4 FTE's!!! Very embarrasing for my XD, especially since I went shooting with a couple of Glock buddies who are always praising their gun (I own a G23c myself) and how they have NEVER had any issues with their weapons.
 

·
Banned
Joined
·
11,479 Posts
DieTrying said:
I have almost had at least 1 FTE each time I have gone to the range. I have over 3000rnds. through my XD-9. I shoot WWB, Wolf, UMC, Fiocci and both CCI Blazer Brass and Aluminum. Tonight was the worst. I shot 200 rounds of CCI Blazer Brass and had 4 FTE's!!! Very embarrasing for my XD, especially since I went shooting with a couple of Glock buddies who are always praising their gun (I own a G23c myself) and how they have NEVER had any issues with their weapons.
Just use the ammo that works the best with your gun and blow the rest off.
 

·
Premium Member
Joined
·
3,955 Posts
DieTrying said:
I have almost had at least 1 FTE each time I have gone to the range. I have over 3000rnds. through my XD-9. I shoot WWB, Wolf, UMC, Fiocci and both CCI Blazer Brass and Aluminum. Tonight was the worst. I shot 200 rounds of CCI Blazer Brass and had 4 FTE's!!! Very embarrasing for my XD, especially since I went shooting with a couple of Glock buddies who are always praising their gun (I own a G23c myself) and how they have NEVER had any issues with their weapons.
That is too many and too (in)consistant. Back to Springfield for some lovin'.
 

·
Registered
Joined
·
63 Posts
Hey Don,

Thanks for the input...I was and have been actually thinking the same thing, but I really don't want to have to go through the trouble of sending it back to SA...even though they are friendly on the phone when I have called, when I start talking about issues with my XD, they kind of start backtracking and make it sound like there is nothing wrong with my gun. I hate having ANY trouble with products that I buy...customer service is always a bitch.
You on the other hand are an exception, you volunteered your help and services before I even thought of asking.
I guess I will call SA on Monday and listen to how normal it is to have FTE's etc.
 

·
Registered
Joined
·
275 Posts
Call springfeild and ask if they have a gunsmith in your area that can bill them direct for any repairs needed I dont know if it will work or not but spring feild backs up there product....
 

·
Premium Member
Joined
·
9,097 Posts
the ox said:
Yeah i been using the winchester white box ammo but I have shot about 500 rds with it and had no problem


ahh yes wwb the usual culprit. all new xds shoot it fine, but when the extractor finally breaks in it wont extract the wwb. u have to switch ammo. try blazer or american eagle. problem is the lip on the wwb casing isnt as deep as other brands. it(the gun) extracts wwb when new because of the extra tension associated with the extractor being new, and not broken in. in "theory" a gun should cycle every ammo, but in the real world thats just not the case.
 

·
Premium Member
Joined
·
594 Posts
My XD gets attention if I have anything less than 1000 MRBF in a given period of time. Thankfully, I have a gunsmith that lives less than a mile from my house so when I have minor problems, I just take it to him at his shop.
 
1 - 13 of 13 Posts
Top