Springfield XD Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Ok guys, my XD has had around 50 rounds through it. No problems. I noticed with some A-Zoom snap caps, with the slide locked open and a mag inserted, they chamber fine on slide release, the extractor catches the case, when i pull rack the slid though, the chambered round ejects and the next one chambers, but the extractor almost have the times doesnt catch, and so the action sits open about 1/8 of an inch...Whats going on?
Thanks
John
 

·
Premium Member
Joined
·
16,428 Posts
Are you pulling back the slide and then releasing it or are you riding the slide forward as you chamber the round?
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
I slingshot it and its done it, but when "Riding the slide" it does happen most of the time, I just want to make sure when I am racking the slide that the extractor is catching on feed and not being forced over the lip of the round every time, you know what I mean, so I find myself riding the slide a bit with the snap caps, just because its got my worried its jumping the lip of the round.
 

·
Premium Member
Joined
·
16,428 Posts
As long as you don't ride the slide the gun will work as designed, slowing down the chambering process is what causes the problems.
 

·
Registered
Joined
·
329 Posts
I only use one snap cap at a time. Just pull the slide back a bout a 1/4" and it will reset the striker and leave the snap cap in for another go round.
 

·
Registered
Joined
·
536 Posts
I only use one snap cap at a time. Just pull the slide back a bout a 1/4" and it will reset the striker and leave the snap cap in for another go round.
yep same here...Plus I mix them in with my ammo at the range to practice safe FTF/FTE discharging procedures as well as tell what I am doing wrong with my wrists.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #11 ·
I think you where right I may have been lightly riding the slide, even though I thought I wasnt, just anticipating that it wouldnt catch properly, and that was causing the issues. It obviously was not present during actual firing because the rounds cycled the weapon, and I was just releasing the slide no need to even touch it. Thanks
 
1 - 11 of 11 Posts
Top