Springfield XD Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
I already posted this in the gunsmithing section but noticed more members view this section.

For the past couple months its been getting worse and worse. XD9 with about 12k rds through it. All original parts. I have 5 mags that I use, four 16 rds and one 15 rd. The gun gets beat up as do the mags. Tactical shooting classes every week. I reload my own ammo but have been for quite a while and use all the same recipes. This just became a problem over the past couple months. First started doing it here and there now it does it just about every empty mag, not specific to any one mag, they all do it randomly. I'm going to run some factory ammo through it tommorow but I'm almost positive it has nothing to do with my reloads. I usually make really weak loads for soft recoil and never had a problem, but tonight I made up some really hot loads to fire through a snailtrap. Loaded each mag several times with one rd each and still the slide only locked back a couple times. I know the slide is coming all the way back when fired so it should catch. Never had a single ftf either. Racking the slide by hand with an empty mag locks the slide every single time so that confuses me too. I'm thinking maybe the mag follower? The mag spring? The slide lock lever spring wore out? I'm lost, any ideas would be greatly appreciated.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #2
I'd say is you right hand thumb!!!
I don't believe it be my thumb. I've been shooting this gun for a long time and have put quite a few thousand rds through it and its never been a problem until recently. I also run a lot of one handed and support hand drills in my classes and still have the problem.
 

·
Registered
Joined
·
23 Posts
My buddy had a Para that did that do him when he bought it used he opened up all the mags stretched the springs out and that was his only problem. Do you keep all your clips loaded up all the time?
 

·
Registered
Joined
·
59 Posts
Discussion Starter #5
My buddy had a Para that did that do him when he bought it used he opened up all the mags stretched the springs out and that was his only problem. Do you keep all your clips loaded up all the time?
I might try that tonight. Stretch the springs a bit and run a few rds through. Just a temporary solution if it works but at least I will know I need to buy new springs. None of the mags for this gun stay loaded, its just my range gun. Seems weird that they could all start to go at the same time but I guess its a possibility.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #6
Just to confirm the thumb thing, shoot it left handed, that will tell you for sure
I'm going to try this tonight as well just for sag. Although I know during some support hand drills last week it didn't lock back several times at the last rd. Very frustrating trying to get a decent time during speed drills!
 

·
Registered
Joined
·
6,595 Posts
I'm going to try this tonight as well just for sag. Although I know during some support hand drills last week it didn't lock back several times at the last rd. Very frustrating trying to get a decent time during speed drills!
It does seem like you are not having the thumb issue, but that is the most common problem with slide not locking back so its good to confirm the shooter before the gun.

Kind of like checking to see if your mower has gas when it doesn't start.....

Good Luck
 
1 - 7 of 7 Posts
Top