Springfield XD Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
340 Posts
Discussion Starter #1
Yesterday after going to the gun range I cleaned the gun. When I reassembled it and put the slide back on I looked at the front of the gun and saw the recoil spring was sticking out from the front. It usually sticks out a few mm, but this time after putting the gun together it was sticking out at least 1cm.

I disassembled the gun again, took the spring out, put it back in and put the slide back on. The spring was still sticking out further than normal. I wasn't sure what to do so I just pushed on the spring a little from the front and it popped back into place. It looks normal now.

Is this ok? I'm not sure what caused that to happen and I want to make sure that the next time I shoot it it's going to be ok.
 

·
Registered
Joined
·
1,072 Posts
I am confused. Can you post a picture? Where is the spring coming out off? What pistol are you using? Is your guide rod short and the spring is going through the guide rod hole?

This doesn't sound normal to me.
 

·
Registered
Joined
·
128 Posts
I'm confused as well. I can't think of any gun that has the recoil spring sticking out the front under normal operating conditions... Type of gun and any mods would help.
 

·
Registered
Joined
·
340 Posts
Discussion Starter #4
xdm compact 3.8 9mm. It doesn't really stick out normally, I worded that wrong. It's seated in the spot on the slide under the barrel. It's just not flush with it, barely poking out normally. I can't recreate the way it was sticking out that concerned me to take a photo. I've tried stripping it a few times and putting it back together since it happened, and every time it's gone back together fine
 

·
Registered
Joined
·
44 Posts
i belive this is what he means





 

·
Registered
Joined
·
340 Posts
Discussion Starter #7
Thanks zenophobe! That was exactly what I meant. Mine was sticking out slightly further at first though.

I went to the range again today to shoot, mentioned the problem to some people that worked there and they glanced it over and said it looked alright.

I shot it today with no problems.


You may have a dirty guide rod assembly or a bur...spray it out and off with gun scrubber and then reassemble the gun...lock slide back and check for burrs
Thanks, I'll keep that in mind if it happens again.
 

·
Registered
Joined
·
44 Posts
You may have a dirty guide rod assembly or a bur...spray it out and off with gun scrubber and then reassemble the gun...lock slide back and check for burrs

The gun in my pics has never been fired.. Just pulled it out the box from picking it up from my FFL.
 

·
Registered
Joined
·
1 Posts
Have you had this problem again? Just recently purchased a 3.8 9mm compact and had that issue the first time I reassembled. Has happened a few times since but I can't get it to do it when trying to show someone. Did you discover what it was? Just curious. Thanks.
 
1 - 10 of 10 Posts
Top