Springfield XD Forum banner

1 - 10 of 10 Posts

·
Banned
Joined
·
31 Posts
Discussion Starter · #1 ·
I am wondering if my XD-40 has an ammo feeding problem. When I rack the slide it feels like there is a rough spot around the loading ramp. It feels like the tip of the bullet is catching somewhere on the loading ramp. I have only fired 350 rounds through my XD. On the other hand my friends Glock 22 and his Sig don't seem to have a rough spot. Could there be a potential problem here or do I need to go and break it in more. I appreciate any advice you guys could offer.
 

·
Registered
Joined
·
242 Posts
I think its normal because mine does that everytime with 3 different bullets. If you rack the slide and let it in slowly then it will seem like there is a problem but if you rack and then let it go it works fine. No damage to the bullet or chamber is apparent either.
 

·
Registered
Joined
·
311 Posts
1st lock the slide back, then jiggle the barrel, it should have a bit of play. Look and feel the point where the barrels feed ramp meets the frames ramp. It should be flush and smooth when the barrel is pushed back towards the ass end of the gun. Start with checking that.
hope this helps.
 

·
Premium Member
Joined
·
3,601 Posts
Ironhide
I am wondering if my XD-40 has an ammo feeding problem
Have you had any failures when firing?
When I rack the slide it feels like there is a rough spot around the loading ramp. It feels like the tip of the bullet is catching somewhere on the loading ramp.
You should be pulling the slide back and letting go firmly to chamber a round, you should never ride the slide home, slowly. If you are slowly chambering the first round, sure you will feel resistance. The nose of the bullet is working it's way into the chamber. Remember, let the slide and spring do the work in chambering your first round. You do your part being a safe and accurate shooter.

Good luck.
 

·
Premium Member
Joined
·
3,601 Posts
I think its normal because mine does that everytime with 3 different bullets. If you rack the slide and let it in slowly then it will seem like there is a problem but if you rack and then let it go it works fine. No damage to the bullet or chamber is apparent either.
why is this person attempting to answer questions, when they havn't even fired 1 shot from their own pistol yet? :x :!:
 

·
Premium Member
Joined
·
3,601 Posts
pardon me I didn't know you are a skilled professional loader. Sheeesh!
 

·
Registered
Joined
·
2,637 Posts
hobocircus said:
I think its normal because mine does that everytime with 3 different bullets. If you rack the slide and let it in slowly then it will seem like there is a problem but if you rack and then let it go it works fine. No damage to the bullet or chamber is apparent either.
why is this person attempting to answer questions, when they havn't even fired 1 shot from their own pistol yet? :x :!:
He has 243 posts in one week--he must be an expert :?
 

·
Premium Member
Joined
·
9,097 Posts
I am wondering if my XD-40 has an ammo feeding problem. When I rack the slide it feels like there is a rough spot around the loading ramp. It feels like the tip of the bullet is catching somewhere on the loading ramp. I have only fired 350 rounds through my XD. On the other hand my friends Glock 22 and his Sig don't seem to have a rough spot. Could there be a potential problem here or do I need to go and break it in more. I appreciate any advice you guys could offer.
Awwwww the Klansman's gun no workie. :neutral: :lol:
 
1 - 10 of 10 Posts
Top