Springfield XD Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello, first post here! I just got a XD-M Elite 9mm with a 4.5 inch barrel. In dry firing it I notice the reset has one distinct click before the actual reset click. I had a co-worker who is also very experienced with guns dry fire it and he said it didn’t feel right, noting the same issue. My Hellcat didn’t do that, nor does it now with an Apex trigger system, my issue Glock 23 does not do this either. In all my decades of shooting I’ve never encountered this. Being new to this platform and the match trigger in this gun I’m wondering, is this is normal on this gun? Haven’t had a chance to call SA support yet.
 

·
Registered
Joined
·
43 Posts
Hello, first post here! I just got a XD-M Elite 9mm with a 4.5 inch barrel. In dry firing it I notice the reset has one distinct click before the actual reset click. I had a co-worker who is also very experienced with guns dry fire it and he said it didn’t feel right, noting the same issue. My Hellcat didn’t do that, nor does it now with an Apex trigger system, my issue Glock 23 does not do this either. In all my decades of shooting I’ve never encountered this. Being new to this platform and the match trigger in this gun I’m wondering, is this is normal on this gun? Haven’t had a chance to call SA support yet.
I have the same pistol and it does the same thing. When I first dry fired it I couldn't believe how short the reset was, until I cycled the slide and tried to dry fire again and realized the trigger had not actually reset. The true reset (as you know) is a little longer but still quite good. I've put about 500 rounds through the pistol without any issue and do not notice this when firing live ammunition.

Enjoy your XD-M Elite, they're fun pistols!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thanks for your response, I appreciate it. Just doesn’t seem right, I have 5 semis autos and one issued one and none do that. Maybe its aftermarket time already....
Bob
 

·
Registered
Joined
·
43 Posts
Thanks for your response, I appreciate it. Just doesn’t seem right, I have 5 semis autos and one issued one and none do that. Maybe its aftermarket time already....
Bob
Your gun, your choice. If you haven't had your new XD-M to the range yet, I'd suggest putting a few hundred rounds through it before making any decisions. You may find this is more of a theoretical problem than an actual one.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Good idea, I just don’t want a different feel between guns that I may have to depend on for defensive use, but your right, it may not be a big deal shooting it. For sure will bang off some rounds first.
 

·
Registered
Joined
·
43 Posts
Good idea, I just don’t want a different feel between guns that I may have to depend on for defensive use, but your right, it may not be a big deal shooting it. For sure will bang off some rounds first.
I can appreciate that. Honestly, I don't notice it at all at the range, only during dry fire.
 

·
Registered
Joined
·
1 Posts
It’s not an issue, at least for me it wasn’t. I took mine out to the range and ran 200 rounds through it and never noticed it when used in live firing.
 

·
Registered
Joined
·
18 Posts
I just got mine a few days ago and I get the same 2 clicks on reset. Haven't fired it yet but if there are no issues like most have stated I won't worry about it.
 

·
Registered
Joined
·
8 Posts
I did some research on this. My Elite 4.5 does this when riding the slide. If you slingshot it never happens. This is what occurs during normal firing so I do t see it as an issue just how it’s designed. I thought it was odd too at first till I figured out what caused it.
 
1 - 11 of 11 Posts
Top