Springfield XD Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Well I just saw a link to this forum on LS2.com and thought I would sign up after checking it out a bit. A little about myself, I am 27 and live in Southern Cali (don't shoot me). I have a few handguns(including my broken XD), :oops: :x a few rifles, and a shotgun. This seems like a cool place and a lot of knowledge floating around here about guns in general and not just XD's. But I do have a question about my XD today.

OK I was cleaning my XD40 at a buddy's house the night before we were to go on a shooting trip. Everything was fine until I slid the slide back onto the frame. I don't know what the heck happened, but somehow my slide got jammed up. I slid the slide on as usual and it seemed fine until like half or 3/4 of the way. Then it was difficult. So I stopped. By then it was too late and here is a pic of its current status. http://i12.photobucket.com/albums/a234/gmeapush/xd40.jpg
I figure I am going to have to go to a gunsmith to see if they can take care of this. Does anyone here have an idea on what happened or has it happened to anyone else? I even tried using a rubber mallet to try and knock it off but I didn't want to bang on it too hard as I didn't want to further any damage.

Edit : here are 2 more of how it looks
http://i12.photobucket.com/albums/a234/gmeapush/XDside.jpg
http://i12.photobucket.com/albums/a234/gmeapush/XDFS.jpg
 

·
Registered
Joined
·
1,167 Posts
The guide rod is designed so that it is two pieces, a skinny one inside of a larger one. The guide rod is inserted properly but I see one problem.

Your slide is forward but your disassembly lever is still up.

Take hold of your gun with your weak hand, holding the slide between the ejection port and the front sight. With your strong hand, using your index finger and thumb shaped like a "U", strike the pistol thus when you hit it, you're engaging the grip safety, at the same time pushing the frame forward while your hand holds the slide.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Thanks for the replies everyone. I also PM'd Ajames about it. I think he hit the nail on the head. The guide rod probably slipped out of place during reassembly. Hopefully how he described to get it apart will help. I will let you all know the results when I get a chance to take a whack at it.
 
1 - 7 of 7 Posts
Top