Springfield XD Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Went to the range all excited I got my Eotech back from repairs.
Started to sight in and was getting a good group and then a round would go a foot to the left! It kept doing this with a stray round going to the left after two or three shots. By this time I'm getting pissed and a round gets stuck in the chamber it did not seat completly into the chamber and would not extract. I had to put a old cleaning rod in and had to slam it on the ground repeatily to dislodge it. I've never in 18 years of shooting M-16 and ARs have seen anything like this! The round was not fired and as for the Eotech its tight and its mounted correcly.
Has anyone had these problems, if so any comments and solutions would be great!!
SS
 

·
Banned
Joined
·
1,082 Posts
I dont think your stuck round has anything to do with the EOTech. Do you reload your own ammo? It could be an out of spec round. You said that the round did not fire... Did you actually pull the trigger and nothing, no boom? If you did pull the trigger, does the primer show the indentation from the pin hitting it?
 

·
Registered
Joined
·
975 Posts
Is the barrel tight to the receiver??? What kind of ammo were you running when you had the round get stuck??


-Derek
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Yea not so clear, still pissed. The Eotech stopped comming on changed batteries and all the trouble shooting. They replaced the piece that holds the Batt. and the contacts on the sight were replaced. Very fast turn arouind less than a week!The upper is a Delton assembly and DPMS lower the rounds weren't the cheapest bulk ammo but not the best either
The bolt didn't even seat completly when it stuck in the chamber so I don't understand how it could have been that far out of tollerance you would think it shoulda been noticeable to have not seated in the chamber. But anyway gonna get some different ammo and try again and see what happens.
SS
 
1 - 7 of 7 Posts
Top