Springfield XD Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I am not sure if this is the right place for this thread but here goes.

Has anyone mounted a FF on a XD/M ? I took mine off a .22LR rfile (where it was working fine) and bought the Burris mount and put it on my XDM 3.8. I noticed that the red dot was "way high" in the viewing window, I had to move my head down to the floor and look up through the FF to even see the dot. I tried adjusting the elevation screw and that moved it a littler but nowhere near where it should be, i.e. resting over the front sight post.

I set it back for repair thinking it was out of calibration or somehow broken. Kudoes to Burris - they sent me a brand new FF shrink wrapped and everything. Very cool.

So I set that on the mount and screwed in the 2 screws and guess what - same problem!

Any ideas - will the FastFire work on this pistol ? Anyone tried it? Thx!
 

·
Premium Member
Joined
·
1,679 Posts
I had one on my XD40 and it appeared to be the same, but as I sighted it in, found that it was dead nutz. I went back to my TruGlo sights and put the Fastfire on my turkey gun.
 

·
Registered
Joined
·
4,448 Posts
I am not sure if this is the right place for this thread but here goes.

Has anyone mounted a FF on a XD/M ? I took mine off a .22LR rfile (where it was working fine) and bought the Burris mount and put it on my XDM 3.8. I noticed that the red dot was "way high" in the viewing window, I had to move my head down to the floor and look up through the FF to even see the dot. I tried adjusting the elevation screw and that moved it a littler but nowhere near where it should be, i.e. resting over the front sight post.

I set it back for repair thinking it was out of calibration or somehow broken. Kudoes to Burris - they sent me a brand new FF shrink wrapped and everything. Very cool.

So I set that on the mount and screwed in the 2 screws and guess what - same problem!

Any ideas - will the FastFire work on this pistol ? Anyone tried it? Thx!
Once its sighted in it does not matter where the dot is in the viewing window, as long as the dot is on the target you will hit it.

don
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Yes I have used RDS before but if I push the gun out in a normal grip/stance, I can't see the dot at all. It's like it cranked way up out of view and the adjustment screws don't move it far enough down. Maybe I will try to get a photo because I am not explaining this well. Thanks for the suggestions tho.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #9 ·
Well I finalkly got it working. Burriss sent me a few more of the plastic mounts that go into the rear sight channel after I destroyed the first one - that sight channel is tight! So I used a sight pusher rather than hammer and punch and got it in. Next I sent the FF back to Burris and they sent me what looks like a new one. Mounted that and it seemed to have the same issue but I toook it to the range and somehow the dot shows in the right place now. It works OK but I think I like the regular iron sights better - or maybe I just need to shoot it with the FF a bit more and get used to it.
 
1 - 9 of 9 Posts
Top