Missing chamber indicator.

Discussion in 'XD-S Discussion Room' started by Badfish602, Jan 20, 2013.

  1. Jan 20, 2013 #1
    Badfish602

    Badfish602 XDTalk Member

    Joined:
    Feb 29, 2012
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Phx, AZ
    Ratings:
    +0 / 0
    While shooting today I was doing semi rapid fire drills. 2 shots on the right target, 2 shots on the lower target and then step over and 3 shots on the left target.

    When i moved over to the left target to take my three shots i noticed that the chamber indicator was sticking up so high that i could not see my front site. By the time i noticed it was that high, i had already pulled the trigger. Then my gun jammed.

    The casing didn't fully eject. After clearing the jam I noticed that the chamber indicator was missing. We could not find it.

    Has this happened to any one else on here?

     
  2. Jan 20, 2013 #2
    nismogsxr

    nismogsxr XDTalk Member

    Joined:
    Sep 20, 2011
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Monroe, NC
    Ratings:
    +0 / 0
    Havent heard of that one yet. Sounds like a trip to springfield
     
  3. Jan 20, 2013 #3
    Badfish602

    Badfish602 XDTalk Member

    Joined:
    Feb 29, 2012
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Phx, AZ
    Ratings:
    +0 / 0
    That's what I'm thinking.
     
  4. Jan 20, 2013 #4
    CountryBoy

    CountryBoy XDTalk 100 Member

    Joined:
    Jan 1, 2013
    Messages:
    374
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Central FL
    Ratings:
    +0 / 0
    Never heard of that one before. That bad boy would be in the mail on Tuesday!
     
  5. Jan 20, 2013 #5
    MrStarofDavid

    MrStarofDavid XDTalk 2K Member

    Joined:
    Feb 27, 2010
    Messages:
    2,198
    Likes Received:
    30
    Trophy Points:
    48
    Location:
    Phoenix Arizona.
    Ratings:
    +72 / 0
    Interesting... I never heard of this. I better make sure mine are set right. Call Springfield and they will replace it.
     
  6. Jan 20, 2013 #6
    Badfish602

    Badfish602 XDTalk Member

    Joined:
    Feb 29, 2012
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Phx, AZ
    Ratings:
    +0 / 0
    $ImageUploadedByTapatalk1358733049.451260.jpg
     
  7. Jan 20, 2013 #7
    DanielChamberlain

    DanielChamberlain XDTalk 100 Member

    Joined:
    Jul 27, 2012
    Messages:
    191
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Near St. Louis
    Ratings:
    +4 / 3
    Have'm send you a new part, a pin and spring and fix it yourself.
     
  8. Jan 20, 2013 #8
    Badfish602

    Badfish602 XDTalk Member

    Joined:
    Feb 29, 2012
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Phx, AZ
    Ratings:
    +0 / 0
    That's what I would like to do.
     
  9. Jan 20, 2013 #9
    Jimmycrackcorn

    Jimmycrackcorn XDTalk 500 Member

    Joined:
    Nov 20, 2010
    Messages:
    741
    Likes Received:
    32
    Trophy Points:
    28
    Ratings:
    +89 / 2
    Only read once of this happening. I think it will function without it.

    Sufficient unto the day is the evil thereof.
     
  10. Jan 20, 2013 #10
    MarkB

    MarkB XDTalk 1K Member

    Joined:
    Jun 28, 2010
    Messages:
    1,079
    Likes Received:
    3
    Trophy Points:
    0
    Location:
    Milton, DE
    Ratings:
    +3 / 0
    The pin is in place. The indicator must have split at the hole and came out.
     

Share This Page