Golden Rod Gunsaver Dehumidifier....HELP!!!!!!!!!!!!

Discussion in 'XDTalk Chatter Box' started by HPD SRT, Apr 18, 2008.

  1. HPD SRT

    HPD SRT XDTalk 1K Member Founding Member

    Joined:
    Dec 23, 2006
    Messages:
    1,478
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Southeastern WA
    Ratings:
    +0 / 0
    I just installed this baby in my new safe. But the way they have the cord is rediculous. Instead of a standard AC plug in for feeding the wire through the small hole in your safe, they have this weird 2 pronged deal that is supposed to go through two holes in the wire. One positive and one negative. Anyway, they make contact and heat the rod.
    My questions are, have any of you guys ever had problems getting the prongs to make contact? I installed it and went out to dinner for an hour or two and came home to find that the rod was still cold to the touch. Is this normal? Or should it be warm to the touch? I assumed it would be at least a little warmer than the rest of the safe. But no, I even tried making sure that these prongs had a clear path to the wire before I went to dinner. But it's still cold. So I need help, suggestions and even pictures if any of you have time. Anything that can help me make this thing work.
    I really don't know of anyway to test to see if it is working, other than touching the rod. So any help will be much appreciated. Thanks.

     
  2. Old School

    Old School Super Moderator Staff Member Supporting Vendor

    Joined:
    Dec 19, 2003
    Messages:
    8,910
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Illinois
    Ratings:
    +8 / 1
  3. HPD SRT

    HPD SRT XDTalk 1K Member Founding Member

    Joined:
    Dec 23, 2006
    Messages:
    1,478
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Southeastern WA
    Ratings:
    +0 / 0
    Thanks. Did you ever have any issues with the wires on your GR? I mean the prongs making contact that is?
     
  4. HPD SRT

    HPD SRT XDTalk 1K Member Founding Member

    Joined:
    Dec 23, 2006
    Messages:
    1,478
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Southeastern WA
    Ratings:
    +0 / 0
    Got it never mind. Wow such a long post for me just to fix it myself..........:roll:
     
  5. Houseboat

    Houseboat Official Site Vendor Supporting Vendor

    Joined:
    Jan 13, 2007
    Messages:
    2,510
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    Tennessee
    Ratings:
    +8 / 0
    The golden rod is the way to go..and it will be hot to the touch..but it does work..
     
  6. HPD SRT

    HPD SRT XDTalk 1K Member Founding Member

    Joined:
    Dec 23, 2006
    Messages:
    1,478
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Southeastern WA
    Ratings:
    +0 / 0
    Thanks. Yeah It's hot now:) I think I had it plugged into a socket that wasn't getting power on my power strip....:roll:

     

Share This Page